Resolved
Audience services have now returned to full health
Monitoring
We have no resolved the issue with a very small number of batches not being updated, and are actively monitoring to ensure normal health is resumed
Identified
We have identified an issue with our audience services that is preventing some users from updating the status of certain batches. We are actively working on a resolution.