Resolved
All long-running export jobs have now completed or been cleared, and performance is back to normal.
We are continuing to monitor, but there are no further delays and no action is required from customers.
Monitoring
Root cause identified and fix applied. Performance is recovering and significantly improved, but we are continuing to monitor.
Investigating
Currently investigating performance degradation on Survey Exports. Exports to Datasets are taking longer than usual to complete for some users.