Resolved
Survey Builder performance has stabilised and all functionality is working as normal.
Monitoring
The issue has been identified and resolved. We are actively monitoring to confirm full service restoration.
Investigating
We are experiencing intermittent issues on Survey Builder where some processes are taking longer than usual to complete. This is impacting the loading of the Overview page for surveys and creation of survey exports in all formats. We are actively investigating and will provide an update in 30 minutes.
Resolved
No further errors have been reported. Survey Builder is working as normal.
Monitoring
The issue has been identified and resolved. We are actively monitoring to confirm full service restoration.
Investigating
The team in investigating intermittent issues with timeouts and errors on Survey Builder.